WWW . TEL . COMMUNITY - The .tel domain forum

Welcome to the Tel.community.

You are invited to participate in the growing .tel
community!

To take full advantage of everything offered by
our forum, please log in if you are already a
member or join our community if you're not yet.

The registration at TelTalk.org is free and easy!

Thank you for participation!
WWW . TEL . COMMUNITY - The .tel domain forum

Welcome to the objective forum for .tel domains! Read it first when anything is happening with .tel!

Please join the LIVE CHAT for all REGISTERED members at the bottom of our forum!

A couple of usability issues re Telnames .tel domains

Share
avatar
mikeseaton
High-Flyer
High-Flyer

Location : Dorset UK
Join date : 2012-06-11
Posts : 2225 Points : 45298
Reputation : 836
Warning level : 100 %

A couple of usability issues re Telnames .tel domains

Post by mikeseaton on Thu 16 Jan 2014, 6:03 pm

Suppose you have just come across a Telnames .tel for the first time - take the demo site http://YourBusiness.tel as an example.

1.

It's pretty standard internet practice that if you hold the cursor over an image and the hand symbol appears then if you click on the image it either takes you somewhere or the image enlarges.

Try this on one of the slideshow images on http://YourBusiness.tel - the hand symbol (I'm using IE) appears, click on the image and nothing happens !.

2.

How is someone new to a Telnames .tel supposed to know they can click on the text header to minimise the text area and display the background photo ?

Minor points they may be - but in business when looking for new customers first impressions of professionalism do count !

http://MikeSeaton.tel


___________________________________________________
Domain Sales: Sedo
eBay Shop: Mike 321 UK
Search Engines: Web | Video | Facebook | Google+ | Pinterest | Tel | Twitter
avatar
Toptel
Senior Member
Senior Member

Join date : 2012-07-02
Posts : 448 Points : 12472
Reputation : 319
Warning level : 100 %

Re: A couple of usability issues re Telnames .tel domains

Post by Toptel on Thu 16 Jan 2014, 7:12 pm

One more thing:
The white color for the gallery background must have run empty. Why the hell it's black?
A severe case of color blindness of the programmer???
Nobody at Telnames who noticed this obvious mistake before going live???

    Current date/time is Sat 16 Dec 2017, 7:12 pm